Incorrect animation movement from Mixamo/Unity fbx file

I’ve been trying to import model and animation in three.js via FBX importer, from model/animation that I made in Unity and exported in FBX format i’m getting movements all over the place. From Mixamo I’m getting the same behavior.

I’m using sample files from three.js (webgl_loader_fbx.html)
I’m using characters named Remy and Mouse.
The animation is captured from Glycon Mocap, but animation from Mixamo is also producing wrong movements with Three.js.

This is not what it should be doing.

This is expected behavior from Unity WebGL.

I don’t know if this is bug, so please correct me if I’m wrong. If i’m missing anything, i’m glad to read to learn.

Thank you very much.

Unity 2020.1.8f1
Unity FBX exporter 3.2.1-preview.2

The model from this example is also from Mixamo and it works without issues:

@looeee I’m not sure but are there any existing issues with Mixamo FBX files and FBXLoader?

BTW: The following thread might be interesting for you:

1 Like

Thank you for your reply! Much appreciated.

I’ve cloned the whole github repository again and ran it at my local computer, imported FBX from Mixamo and it does indeed work flawlessly. However, if I import the animation + model (both from Mixamo) i’m getting different results.

The model is moving at the ground but the whole model is still keeping “silent”. Here is the file from Unity FBX exporter:

Okay, I think I’ve solved it.

As reference for everyone using Unity as FBX export and using it in Three.js.

As opposite of a tutorial somewhere you have to set Animation Type from Inspector sidepane to Legacy (both animate and model), not Humanoid. When set to Humanoid, Three.js is interpreting the movement not correctly. Legacy is the only way to go.

In any case, I hope this helps with any developement of Three.js.


Not with any models I’ve downloaded from Mixamo. However, there are sometimes problems with models uploaded to Mixamo and exported. I think what happens is that Mixamo doesn’t change the underlying FBX data, it just adds/replaces a skeleton and animation. If there are issues with the original FBX, they won’t be fixed by uploading to Mixamo.

Anyway, it seems like the issue here is with Unity FBX. @Gomer_Otterspeer glad you were able to solve it!



as it seems to me, this is not an issue with Unity only.
It seems more, that this issue lies within the meshes/ models.

How can I say ?
I loaded several models, which I downloaded from Mixamo, into a js- script which got hold of the animations all the models had, usually 1 per model.
Then all the animations were… bundled into a js-file which now can be loaded to provide all animations to all models . scene . animations .

This works, for some models, so they can use all animations, whether it is walking or running oder jumping and so on.

Some models do resist the injection of animations somehow.
They run as they shall, when only used with the animation that is downloaded with them but not when I tell them to use the formerly extracted animation or a different formerly extracted, as described above.
Ways are adapted so when I use an animation “walk in circles” or so, the model follows a circle but stays, in the T-Model-pose ( with glitches ).

As I do not have any graphics affinity, I can only tell as a programmer.

Maybe the models have an internal switch which I can reach, with javascript, to enable the adoption of animations ?

In fact, on the Mixamo website, you can use every animation on every model.