How to enable webxr passthrough for quest2?

Anyone know how to turn on passthrough for threejs or if that feature is even added yet?
This demo seems to have done it: https://youtu.be/mvzPprYgflo, but there is no documentation anywhere. Thanks.

1 Like

Is that demo being executed purely in a browser? Or more like an app that has a browser embedded? :thinking:

Figured it out:

  1. webgl renderer must be transparent (alpha:true in threejs)
  2. canvas must be transparent (background:none)
  3. must enter immersive-ar (not immersive-vr session)
  4. quest2 must be running version 46 or higher
  5. turn on passthrough mode in quest2 main settings
2 Likes

@FuzzyWobble hm… just got the same idea to create something with passthrough mode, saw the example… But can’t make it work. First spent several hours just to update my Quest 2, got 46. Actually even that demo doesn’t work like in AR mode. Do you have any ideas?

This demo doesn’t work?
https://immersive-web.github.io/webxr-samples/immersive-ar-session.html

Were you able to turn on passthrough mode in the oculus settings?

Looks like I had to update and reload my glasses several times. Thanks mate!