WebXR inline sessions, no image on canvas - Oculus Rift

Hi, I’ve been developing WebVR apps since 2018. I mostly use Firefox.
I was only able to run them in Chrome for a brief period of time last year.

The first issue I found recently is that the VR view is not shown on the canvas anymore.
The “inline” mode is supposed to do that, but I tried many examples from threejs.org or Mozilla WebXR demo and when you turn on VR mode there is no update to the canvas on the screen.
I also tried these examples

I suppose It may have to do with some update made to Firefox.
Does any experience the same issue?
I have an Oculus Rift CV1.

The other question is, has anyone been able to run any of the examples in Chrome recently?
I enabled all the flags required at chrome://flags but even when the example displays “Your browser supports WebXR …” the button to go on VR mode is disabled

It shouldn’t be necessary to enable flags for using WebXR. Can you please try it without?

On my Pixel 1 and Daydream, the WebXR examples work on Chrome without issues.

I was able to run the examples on Chrome.I found I had to add the following switches to Chrome.exe

–disable-features=XRSandbox --enable-features=openvr --force-webxr-runtime=openvr

The inline sessions still don’t update the canvas while VR is on