Enable 'VR NOT SUPPORT'

Hi @Mugen87 ,
I tried to open WebXR example(e.g. three.js examples ) with chrome in the Oculus Rift.
But I can see ‘VR NOT SUPPORTED’.
Can you tell me the full list of VR devices and web browsers what can support the WebXR(threejs)?
Cheers!

I’m not aware of a list with all devices. However, if the following WebXR samples do not work on your Rift, it’s a general lack of support of WebXR.

Hi @Realitian,

I use Rift as well and this is the process that I use to work with WebXR projects with three.js on my machine (Using Chrome browser).

  1. Firstly, open the Oculus app after connecting the VR device to the computer.
  2. Setup chrome to open with command line arguments like this: (This step will solve your VR not supported issue)

chrome.exe --disable-features=XRSandbox --enable-features=oculus --force-webxr-runtime=oculus

  1. Once chrome has launched, open a new tab and try launching one of the WebXR examples again. It should work.

Let me know how it goes!

Regards
Srinivas

Hi @Srinivas_Prabhu

I tried to your steps, but it does not work.
Still I see ‘VR NOT FOUND’ msg on Immersive VR Session

Cheers.

What chrome version are you using ? Are you using a RIFT S ? Or just RIFT ? Also, can you see when was the last update that you received on Oculus app?

I use chrome Version 90.0.4430.93 (Official Build) (64-bit) and use Oculus Rift.

I had to revert my chrome version to 82. And stop auto updates. And then it worked