No longer able to run WebXR examples with Valve Index

Hi guys – I followed this github issue here:

Up until a week or so ago I’ve been running all of the WebXR examples on the three.js site with no issues on Chrome. Now when I go to them (ex: all I see is “VR NOT SUPPORTED”. I have the flags turned on etc. Also, when I run Firefox Nightly, I see “WEBXR NOT AVAILABLE”.

When I go to I am able to run the demos there just fine (using Firefox Nightly, still no dice with Chrome). So as far as I can tell, something seems out of sync with threejs. It’s just a bummer because I finally got some code ready to test out in the headset and now things aren’t working. Any suggestions?

Examples like this one might work in other browser since they use a WebXR polyfill. That means the API calls might fall back to deprecated WebVR (which was removed from Chrome with version 80). Firefox however still supports WebVR but not WebXR yet.

The three.js examples do not use this polyfill. So you can only use WebXR or nothing.

I suggest you have an eye on the following Chromium bug that seems to track your issue:

1 Like

Is it possible to create a matrix with each threejs release showing XR/VR/AR support on different browsers? It’s getting infinitely confusing with all the releasesXdevicesXbrowsersXupdates to understand what is going on.

This is not really related to three.js. You just have to figure out which devices support WebXR. These should also work with three.js.