Cant enter VR Mode from Browser | Vive Pro


I am stuck at developing a threejs VR project. I can handle and debug via WebXR Extension. Connecting with SteamVR seems impossible, not even the offical examples. Years ago I solved it via Firefox Reality Browser. But the browser got killed and is not available anymore. All alternatives seems not to work with the “Vive Pro”
I tried a lot of things to get this problem done:

Reinstall SteamVR & Viveport.

Changed Flags in Firefox:

Changed Flags in Chrome:

I cant install the following Browser, because Pro wont support them:
Vive Browser
Wolvic Browser

The Settings of both Browsers allow VR-Content to be added and are not blocking.

If I look at three.js examples, the Button shows “VR not supported”
If I select F12 > WebXR the HTC Vive, it allows me to enter Vr in the Browser. But the controls are only available in the DevTools. With unselecting the Vive Pro in Devtools, VR is not supported anymore.

Had anybody else this issue in the last months and knows a Fix for this? I am infinitely grateful for your help. All I can find on the internet is years ago.

I’m also looking for a solution to this. I tried to make Vive work with Three.js, but spend several weeks in vain – I was not able to find a suitable browser, the only available was Forefox Reality Alpha and it crashed for every single web demo that I tried (including its own ones).

There was no problem with Three.js per se, my attempts failed way before reaching Three.js.

Solved it! Its not stable, but at least working to connect SteamVR. Only option at the moment (7.2023) for me is with google canary, its different to chrome and fixes the bridge between openxr and steamvr: Chrome Canary Features For Developers - Google Chrome

the support of htc vive wrote to me, so theres a tiny hope left to get something in Viveport: Unfortunately, there are no VR web browser apps for PCVR devices on Viveport at the moment. Our team is still finding a suitable replacement and hopefully this will be resolved soon.