WebXR broken in Chrome 81+?

Is WebXR broken in Chrome 81+? When try to run the output in chrome 81, the Enter VR is not appearing? After debugging, I understood that the promise for navigator.xr.isSessionSupported is not getting resolved. It is in pending state. Anyone experienced the same issue? Is it a chrome bug? I tried the examples given in threejs github. Those contents are not showing the Enter VR button;

Note: I tried in android chrome beta which is version 83. The same issue is there.

I’ve tested some VR examples from the official website with Chrome 81 on a Pixel (1) and everything seems to work as expected.

I tried playing this output https://threejs.org/examples/webxr_vr_cubes.html in Samsung S9+ chrome beta which is at version 83. I am not able to see the Enter VR button. But it is working fine in chrome 80.

Just tested with Chrome Beta and it works as expected there as well.

I am still facing the same issue. I have tested in multiple phones. I can see the same issue everywhere. Do I need to enable any other flags other than WebXR Incubations?

No, with Chrome 81 WebXR works by default without enabling additional flags.

Are your smartphones using the latest version of Android?

I am using Android Version 10 and Chrome 81.0.4044.117.