Distorted/Garbled image on MacBook Pro16

Hi all,

I’m new here, just wanted to try the three.js and found out that it doesn’t work on my laptop.
Check the attached image. The view is garbled with some horizontal lines. You can manipulate (rotate) objects, but the image stays “ugly”.

It’s top end MBP 16 with the best Radeon Pro 5600m graphics.

Anyone had any similar problems or do you know how I could solve this?

Thanks in advance.

This could be a graphics driver issue. Have you already tried to update it?

Hey, thanks for reply.
I’m running the latest updates of MacOS Catalina.
Never heard of anyone updating graphics drivers on a Mac (like on Windows for example).

  1. That’s a pretty cool effect - I’d count it as a feature, not a bug. :smirk:
  2. And now more seriously, try tweaking chrome feature flags - see if turning on/off GPU-accelerated rendering helps. If it really is a driver / GPU issue - you can’t do much on mac (except for filing an Apple / AMD / Chrome support ticket.)

Edit: a tiny, random idea - see this demo. In JS editor - try running both SET_PIXEL_RATIO = 1 and SET_PIXEL_RATIO = 2, see if there’s any difference.

I actually use Safari and Firefox. I don’t have Chrome installed, but don’t think the result would be different in Chrome as the “effect” is the same in Safari and in Firefox.

I tried the demo and yes, the results are different if I change the pixel ratio. The best looking image is when the ratio is set to 4 but there are still lines over the scene.

When updating the OS, the driver is updated automatically on macOS.

That’s what I meant yes :slight_smile:
I do have the latest updates for Catalina installed.

Maybe you have to switch to Big Sur.

I don’t dare to do that yet :wink:
Will wait for a couple of weeks at least so the OS gets stable. Some horror stories surfaced right after the BigSur release (even bricking some Macbooks) so I don’t want to risk that with my laptop (can’t afford to brick it).

Anyayws, it looks to be what you said - probably some driver issue. So I’ll wait a bit and see if the next update maybe resolves this.

Thanks guys.