The r112 version does not run in the Google browser

My computer operating system is win10 home Chinese version:1903, operating system version:18362.476。The browser is: Google browser V 80.0.3987.53(64 位)。An error occurred while browsing some examples of the r112 version, which cannot be browsed. What’s the problem?

THREE.WebGLRenderer: Error creating WebGL context.
Uncaught Error: Error creating WebGL context.

This often indicates a driver or browser issue.

Is this the official Chrome browser? I thought the latest version is 79.0.3945.130…

Also try to update your GPU driver to the latest version.

Today, on my phone,
79.0.3945.136 is Chrome stable,
80.0.3987.68 is Chrome Beta,
81.0.4035.5 is Chrome Dev and
81.0.4038.2 is Chrome Canary, although that last one changes on a daily basis.

Can you share some information about your phone? How old is it and what hardware (CPU) is used?

Just for clarification: Are you also affected by this issue?

No, I do not have this problem, just wanted to chip in on the browser versions.

I still work with r107, Cordova based app, Oneplus 5t, Android 9, Oxygen OS 9.0.10.

I don’t want to hijack this thread, only reporting the following ‘error’ as it ‘might’ be related to this thread, as it is about a Chromium Dev version and possible related GL errors.

Allthough my app seems to still work fine (no console errors and working just like before) , from the Dev version onwards, I do see a lot of the following Chromium errors in logcat:
[ERROR: gles2_cmd_decoder.cc(18990)] [GroupMarkerNotSet(crbug.com/243999)!:B835075274000000]GL ERROR :GL_INVALID_OPERATION : DoBeginBatchReadAccessSharedImageCHROMIUM: shared image begin batch read access failed

These problems might be totally unrelated, though.

These errors are not shown in the browser console.

It ends with the message that there are two many GL errors, so no more errors will be reporter for that context.

Reloading the app (and library) with F5 (chrome://inspect -> devices), no more errors are seen (reported). Possibly not an error with Three, but more with Chromium itsself.

In this case, consider to file a bug here: https://bugs.chromium.org/p/chromium/issues/list

Thanks, I just appended it to crbug.com/1045242

Edit: I just confirmed it’s not threejs : logcat is flooded by the same messages, from another Cordova app, without threejs.

1 Like

I had no problem with r109 before.

I am a Chinese developer. The Google browser was downloaded from domestic 360 software manager. It is the latest stable version, not the development version.,

You can see the latest stable version of Chrome here:

https://www.chromestatus.com/features/schedule

It’s currently at version 79. Version 80 is the development version, but it’s due for release in 3 days, on Feb 4th.

Is it possible for you to install the stable version 79 and test it?

You can download it here:

2 Likes

I’m not familiar with this and a search is not turning anything up. Do you have a link to this software?

Ok, I’ll go download version 79 and try it. Thank you !

1 Like

I am sorry that I have the same error with version 79 of Google

Hmm, what is your graphics card?

Do you get the same result if you open an incognito window (i.e. with all extensions disabled)?

And can you run any examples? Or do you get the same result from all?

My graphics card is geForce GTX 960M driver version 388.75

Not all examples can not run, now find the first point to the example of materials/physical/clearcoat is wrong, then other examples are also can’t run

Thank you very much for your reply. This problem has been solved.

Because my computer is a dual graphics card, Google browser has been the default to use integrated graphics card, the graphics card is relatively low, I switched to another graphics card problem was solved! Thank you very much!