Skinned mesh FBX glitch just appeared Chrome + MacOS

^^^
Everything was fine then started doing this to animated fbx.
Any idea what this is?

Please share the FBX in this topic.

How did this glitch occur? By upgrading from r137 to r138?

Please understand that you have to provide more background information when reporting such issues. Sharing information about your hardware and browser is also helpful.

Hi all,

We have an issue that looks visually very similar to this, and occurs with all sorts of static meshes. The behaviour is quite odd:

  • the model will render normally
  • sometimes, apparently, at random it will render the vertices all messed up - looks like traingles on the surface are being connected to other surfaces or out into space
  • once this happens it keeps happening and only seems to correct once the laptop is rebooted
  • in the second image you can see one area has not been messed up - it should all look like that
  • the odd thing is it starts out fine and then at some point it just starts doing this to every model
  • happens in Chrome and Safari
  • happens on MacOS - tried upgrading to latest Monterey and the problem persists
  • restarting the computer avoids the problem.

I guess this seems like a webkit or browser issue because of the way it manifests, but it would be great if anyone can offer any support. I can upload models, but I don’t think this will add much - as the models work fine, until they don’t

Many thanks for any thoughts or input

Ive seen this before


(it was “wrong index” problem in the code)

2 Likes

Can you please share what was “wrong index” problem?
Any details would be helpful. Thanks!

In further testing, we found a trigger for this: For us, the issue starts when we add a mesh geometry near to an original mesh - the original mesh glitches like this. It occurs only on some systems (MacOS Chrome or Safari - but not all MacOS systems, although we don’t see any pattern so far). Once the problem starts it will continue even in a new browser window until Chrome (or Safari) is restarted.

And there is. That is the main reason why I decided to stay on the r129 version. The same thing happened to me when I started an animation in my models. I think this is a bug. And if I remember good. those weird bugs started at r133 (on my case)

I mean generally when an index that should be pointing to one vertex actually points to another. A typical cases would be off-by-one indices or missing index attribute (in which case it defaults to the order of vertices in position attribute). However, this normally happens if you work with the geometry manually and not just use some format loader.

Did you try reporting this to @looeee I think he is the one maintaining fbx loaser.

2 Likes

I haven’t worked on the FBXLoader for a few years now as I don’t use it any more.
You could try converting to glTF with FBX2GLTF, or if you’re exporting from Max there’s a Babylon glTF exporter that’s quite good.

I’m having the same problem with meshes loaded using the STLLoader, but only in Chrome on a Mac; Safari is fine. The mesh appears OK until add a TransformControls object to the scene, whence the same apparent vertex indexing issues appears and is not correct until I fully restart Chrome.

Since the problem remains if I freshly reload the mesh, I don’t think it is a loader problem, and the need to fully restart Chrome suggests it is a Chrome code issue.

Running latest of everything, three.js, Chrome, MacOS, etc., etc. Was failing as well on earlier MacOS & three.js versions.

Here is a mesh after restarting Chrome:

Here’s the same mesh, as soon as I add the TransformControls to the scene, with no other interaction:

Should we be bugging Google?

Can you create a codesandbox.io that demonstrates this so that other people can check it?

It seems unlikely that this is a browser bug but if it is we should notify the Chrome team.

This became a big issue on MaxOS with FBX files. If you restart chrome the issue goes away, but after time, reappears. I couldn’t fix the issue so switched to GLTF for now…

@FuzzyWobble do you have a reproducible example? Should really raise this with the Chrome team if it’s genuinely a browser bug.

This has been poster to the forum, I just cant find the thread:
STL

so they posted this to chromium bug tracker

1 Like