3D model (GLB) consisting of several parts is not visible on the stage

I downloaded the 3D model and opened it in Blender. Then, as I usually do, I exported it for the ThreeJS scene (in GBL format). However, it, with the usual addition, as I did on other scenes with other 3d models, is not visible on the scene. Although I tried to scale the scene (zoom in, zoom out, change position).
If I use this resource (Model Editor), then it displays both the model and its animation.
I also added a cube and a sphere for testing. These two items appear on both my scene and that site’s scene.
As I understand it, perhaps there are some parameters that are difficult to guess that need to be changed. For example, I tried to change the size to 0.001 and to 0.5. The two items next to the main model that I added for testing are visible. But the model itself is not.
I also tried various options for exporting the model, with different parameters. This also didn’t work.

Model is here:

but I didn’t understand how to add the static folder there (so that the files from it are available in relative links)

Everything turned out to be very simple. Need to convert all Object3D to Mesh

1 Like

Just curious: did the GLTFLoader say anything about the non-mesh file? A warning in the JS console, maybe?

No. If there were warnings, I would understand at least in which direction I should go. And I arrived at the solution by guesswork.

I had a model at my disposal that had animation and at the same time worked in the browser.
I loaded it into Blender and compared it to the Mandalorian model. In the moment.
I also displayed the GLB object in the console, which appears in the callback function after loading and found Object3D there, not Mesh. This information gave me a reason to try to convert in blender Object3D to Mesh.
But after that the animation stopped working. I have yet to figure this out…

1 Like