Wrong side of the model gets bright while adding lights

Hello all, I have one problem and I’m looking for some hints how to solve it.
So I have a model in GLB format, it was OBJ originally but I converted it to GLB using blender.
I want to use this model in my three.js project but there is a problem with lighting. The model is house and when I put the directional (or any other) light on the scene then the wrong side of the model gets bright. It does not matter if I added the light in blender or in three.js via the code. When I preview the model in the blender everything works fine. Please check images below for better understanding whats wrong. The grass is brighter from the under although the light source is above the model and the house gets brighter inside part of it.

This may not be the overall fix but In blender have you tried to apply all transforms from the object menu? If you try this you’ll also need to set origin, origin to geometry and try to export again

Thanks for the reply and tip. Sadly it did not change anything :frowning:

Is it possible to share the model file and or a live environment in codepen or js fiddle? Does it look correct with other viewers such as gltf-viewer?

Hi, here is the model on google drive: house.glb - Google Drive
I used the tool you have linked here and the problem is visible there. The grass gets light from the underground…

this points to a normals issue, have you checked your face normals of the geometry are all in order and facing the correct way?

When I check the “Face Orientation” checkbox everything looks right for me.

checking the model in blender it seems the error is coming from unwelded vertices, if you go to edit mode, select all vertices and then click m->by distance, this will weld all of the vertices if they occupy the same position, here’s the model corrected which seems to look fine in gltf-viewer…

Sadly this not worked for me :frowning:
I even downloaded your model and inserted it to my three js project and the grass is still illuminated from the below. Also when I put it in this viewer you linked it is not working the way it should. Grass is still brighter from below

try this one…

let me know if this works, this is without your material 's normal map, which is likely causing the problem, you had the normal color set to your grass texture which is not a normal map

Yes, this one works fine. So whats wrong with the others?

your material setup…

1 Like

Thanks for your time and knowledge.

1 Like