Why Editor ground grid lines show and hide?

Is it me or the grid lines in default ground you see in https://threejs.org/editor always shows and hide after certain camera angles and distances? (actually no ground is shown in SCENE tab only a Camera and a Scene)
Actually it can be improved to be better looking if not the most necessary feature to have.

In addition, can it be inspectable like the Camera and Scene or is there a reason for that this ground does not show up in the Editor?

I’m afraid I can’t reproduce this. Can you make a screenshot or video of this glitch?

It is something like that. After a certain angle and distance some lines are hidden.

The grid is rendered as 1px wide lines. Depending on the screen’s resolution and/or GPU (driver) effects like that are inevitable.

I think that should not be the case. It should be doable like I can see it work in the babylonjs playground. I thought maybe we can do this here too. Ideas?

It works probably because of the darker background.

Trying that yielded in same result.

That looks suspiciously like :smile:

So if it’s rendered on a quad it isn’t the same as lines. It could be a issue on your machine. Does the issue appear in other browsers?

1 Like

I’ve tested this on Chrome windows and Brave Android, but I can’t reproduce it.

What renderer do you have selected?


No, it doesn’t appear on other browsers. I am on a mac and Chrome.

That was the original selections.

Selecting same options as in your ss does not seem to change the result:

That’s very weird.
What OS is that with? What graphics card?

macOS 10.13.6 High Sierra
Intel HD Graphics 3000 384 MB


I honestly think this is some driver issue/something locally, intel graphics glitches in many ways as i experienced on various machines. In some cases WebGL rejects it even completely. I always suggest developers as well as consumers to always avoid onboard graphics.

1 Like