Texture blur (when using pixelart) three.js editor

Hello every!
I want to make a Minecraft “ripoff” in the three.js editor and started with the player, but if I attach the texture (which is pixelated) it will blur the image.

i already tried to use following script on the player:


but that didn’t work either. This project is very important to me, so i hope that you can help me.

You’ll want to look at the “minFilter” and “magFilter” settings for the textures:


You can set them to “NearestFilter” to disable linear interpolation of the texture:

texture.minFilter = THREE.NearestFilter;
texture.magFilter = THREE.NearestFilter;

I don’t know how to acces the texture of an object that was created in the editor. Do I just have to use this.texture?

Sorry I’m not familiar enough with the editor to provide help there – the minFilter and magFilter fields are available on the texture object which can be accessed via the material:

mesh.material.map.minFilter = THREE.NearestFilter

lol, thank you so much (i just replace mesh with this)