Suddenly failing on Desktop Chrome (Macbook Pro)

Hi. This site uses a three.js I made for its background, but sometime around late October / early November it stopped working on Desktop Chrome. Works fine on Mobile Chrome, Desktop Safari, and Mobile Safari. I’ve updated threemin.js and checked to make sure I was linked to the latest jquery. Chrome appeared to already be up to date when I checked after it had failed to load.

This what I’m getting:

THREE.WebGLRenderer 98
THREE.WebGLRenderer: Error creating WebGL context.
jQuery.Deferred exception: Cannot read property ‘getShaderPrecisionFormat’ of null TypeError: Cannot read property ‘getShaderPrecisionFormat’ of null
5 squarespace links, limited to 3 links to post
at l (
at c ( undefined
Uncaught TypeError: Cannot read property ‘getShaderPrecisionFormat’ of null
at d (threeminr98.js:29)
at new Sf (threeminr98.js:30)
at c (threeminr98.js:150)
at new ce (threeminr98.js:178)
at HTMLDocument. (polyspace-invert.js:12)
at l (jquery.min.js:2)
at c (jquery.min.js:2)

At first I thought this was because of a Squarespace update (man I would love to host my own hand-written site if I knew anything about back-end) but I assume it can’t be if it works on every other browser I’ve checked. What’s going on?


I’ve tested the website with Chrome 70.0.3538.102 on macOS 10.13.6. Everything seems to work fine. There are no errors in the browser console.

Can you also test other WebGL demos which do not use three.js? It would interesting to know if these applications are able to create a WebGL context.

A moment ago, realizing I’d failed to update from 70.0.3538.77, I was disappointed when I upgraded to 70.0.3538.102 and still had the same problem. I tested regular WebGL, and non are working on my old or new Chrome version. I went though all the suggestions [here] ( and still haven’t resolved the issue. Maybe it’s overkill, but I guess I could reinstall Chrome?

Thank you for testing!

Are you running an older Mac? I ran into a similar issue where Chrome decided my 2011 MBP was too old to run WebGL :roll_eyes:

The fix for me was manually enabling WebGL acceleration under Chrome’s feature flags: chrome://flags/


It’s worth a try.

I am! It’s a 2010. Checked for WebGL acceleration under flags and only found “WebGL Draft Extensions”, which I turned off and back on again. Still no luck on my MBP but if that’s the problem, I’m relieved, and also surprised it wasn’t a simple mistake by me. In my experience of being self-taught, that’s almost always the case.

Yep, will do.

I think the specific setting for this is “Override software rendering-list”. And haha yep, I had a similar reaction when this happened to me :slight_smile: