Stepping effect on intersecting objects. Seems to be caused by bloom pass


I’m getting this odd stepping effect where objects intersect another mesh.

The three black cylinders use the same geometry and a MeshStandardMaterial. All three are scaled by factors of 0.4, 0.6 and 3. I guess the one with the correct smooth intersection is closest to the camera.
The ground mesh has MeshPhongMaterial.

The odd thing is that disabling the UnrealBloomPass prevents this from happening.

Has anyone had similar issues? Any advice on what might be causing the issue?


So I found the problem, thanks to this thread. Seems like it was a depthBuffer precision issue.

I tried enabling logarithmicDepthBuffer, but that didn’t have any effect.

What solved it was setting the camera’s near & far clipping planes from default (0.1 - 2000) to 1 - 1000.

Solved the strange stepping issue and some other minor artifacts too.

1 Like