Prevent culling (?) camera

I want prevent culling (?) at OrthographicCamera.

when i using mouse control, the black side is appear…
what is wrong?
thank you.

cameraOrtho = new THREE.OrthographicCamera( 
      window.innerWidth / -2, 
      window.innerWidth / 2, 
      window.innerHeight / 2, 
      window.innerHeight / -2, 

    cameraOrtho.zoom = 0.3;
    cameraOrtho.frustumCulled = false;
    three.activeCamera = cameraOrtho ;
    cameraOrtho.position.y = 1000;

This is wrong result

This is what i want

What controls are you using?

You need to increase the far plane parameter when creating the camera which you’ve set to 10000 or keep your scene smaller, judging by the camera position your scene/cube is quite large and will get culled by the far plane of the frustum quickly.

Thank you for reply.
I am using
“three.controls = new OrbitControls( three.activeCamera);”

just basic mouse controls.
click and drag .

ok- thank you.
I understand a little bit . thank you,
then, What should I do?
Is it possible to modify it as I want?

You should pick a reasonable distance, like the max. distance the user can zoom out plus about some more of the size of the cube to make sure it will be always within the frustum, by decreasing and increasing the parameter a bit you’ll see the difference.

Just don’t simply use a overly huge number, the larger the far plane is the faster you’ll getting precision issues.

thank you,
I will try again !