Plane Mesh Not Receving Shadow

I’ve got a “flag” animation going and I’m trying to get it to display shadows as it animates and “ripples in the wind” sort of effect - what am I doing wrong?

Here’s the fiddle:

Note how both of my lights are set to castShadows as follows:

light1.castsShadow = true;

and my “flag” object is set to receive shadows:

flagMesh.receiveShadow = true;

I believe it’s .castShadow, not .castsShadow
Also, you can try adding this:
renderer.shadowMap.enabled = true;

You’re right - it is .castShadow , not .castsShadow - however, that’s a typo I made when I posted this question, but in the code I did have .castShadow - and it wasn’t working.

Otherwise, I did go ahead and add:

renderer.shadowMap.enabled = true;

as per your suggestion, but unfortunately that doesn’t seem to be fixing the problem either.

Thanks for those suggestions of course - any other thoughts on how to address this?