Object that has opacity map blinking(z-fighting) with custom camera

Hi guys.

I’m struggling with blinking object which has opacity map.

I can check gltf-viewer don’t make this happen but my own viewer makes this happen only.

what should I check for this symptom?

Blinking goes disappear when I set camera near plane 0.1 to 0.5 but. I have to set the near plane to 0.1 for the object…

Any chances to demonstrate the issue with a live example?

Could you decrease the far value instead? That should improve the depth precision which potentially resolves your issue.

I tried decrease far value to 100 but same result.

My code is quite havy so I think I can’t make the live code…

Besides, I change that material depthTest to false it stoped blink

I think I have to check whether it has opacity map then I turn off the depthTest.

But when I check My model in web console, I found that the alphaMap null

I put gltf file, exported from blender with alphamap but there is no alpha map in console.

what should I check for that?

스크린샷 2022-09-30 오후 6.02.27

I putted the alpha map like this