Line Artifacts on zoom when mipmapping is enabled

^ I create the texture on the image above within a shader material, which processes an input image into a texture for the model, and during the processing I use a color map to draw a each 16x16 pixel tile of the texture, in a way that mimics yarn material. It works great, but when I zoom in, there seem to be these lingering line artifacts (pure white ones you see above), which are only present when mipmapping is enabled. Any idea how I may be able to get rid of them without disabling mip mapping for my minfilter? Thanks!

Hey there!

I ran into your post while having the same problem in a different platform and I found a solution that might work in threeJS:

Hope that helps!