Impossible to set render gamma value

I’m trying to blend colors in Three.js, however it seems that Three.js does some gamma processing that I cannot disable or change. According to documentation, I should be able to tell:

renderer.gammaInput = false
renderer.gammaOutput = false
renderer.gammaFactor = 1.0

However, changing these settings does not affect the final image at all. I’ve created a sample scene in shadertoy here: . Note that the shader converts the colorspace from linear to sRGB explicitely. The results I’ve got are as follow:

Starting from the left to right side:

  • Running the shader in Three.js with explicit conversion from linear to sRGB space
  • Running the shader in Three.js without the conversion
  • Running the shader in shadertoy with explicit conversion from linear to sRGB space (and this is the correct way it should look like).

Changing the parameters described above does not affect how it looks like. It seems to me that it is a bug, because I cannot disable some gamma setting that Three.js is applying. It could be something else, but this is my strongest bet here.

Initially I thought it might be a bug, but I was redirected from github issues here:

Changing material.needsUpdate = true doesn’t affect its behavir.

I would be thankful for any help / workaround. I’ve been reading other threads, like documentation on gamma correction incorrect? · Issue #11110 · mrdoob/three.js · GitHub and tested other options (mentioned to be introduced in the future, but without any success).

Thanks! :slight_smile: