Gltf meshopt compression

Hello everyone,

I’m not sure if anyone else has had this problem but I would appreciate any advice.

I have been using gltf.report to compress my character models. I have a file for animation and a file for the textured mesh. Everything was working perfectly fine but then I tried compressing a new model and it has some strange artifacts.

I have been using this method for a while and have had no problems. I originally thought it was an export issue or something on my end of blender. However, I tried the gltf.report meshopt compression on one of my previously working (and already exported) models and had the same problem. Does anyone know what might be causing this to suddenly start happening and how to fix it?

It is just strange that it just now started happening. A few weeks ago everything was totally fine and now the exact same models that were previously working, now are leading to these weird artifacts. I’ve checked the weights of the model, the normal directions, duplicate verts, compared to other models, but everything is pointing towards the compression.

Thank you in advance for any insights!

The gltf.report website recently updated from glTF Transform v3 to v4. There’s a bug report about this issue at Quantization creates invalid skinning weights for CesiumMan.glb · Issue #1404 · donmccurdy/glTF-Transform · GitHub. I hadn’t been aware it was new in v4, but from your experience it sounds like that is the case.

Until that is fixed, you can work around the issue using the CLI:

npm install --global @gltf-transform/cli@3.10.x

gltf-transform meshopt input.glb output.glb
2 Likes

Thank you for the quick response! I will give that a shot. Cheers.