Export .glb file from Blender without Normals and my 3D model don't load any texture on render and JS callbacks

Hi, I’m Newbbie here

I want to apologize for my english, but I will try my best :sweat_smile:

I’m trying to reduce my 3D model size, currently is with 60mb, and when I export a .glb file on Blender, without any configuration, just the ‘Transformation → +Y Up’, when model loads on my application it’s appears without color/texture/material and have the same result when I try to change using JS commands.

I’ve already tried to inspect the model in the browser console and do a lot of tests changing the objects materials properties, but without any result.

I’m looking for a solution to keep using/exporting .glb files from Blender without the ‘Normals’ includede in the file, or maybe another way to ‘compress’ the file, because with that ‘method’ the file size was 60mb and went to 34mb. I tried to use the ‘Compress’ tool on .glb export from Blender and the final file had 7mb, but didn’t open/load on my application and anyanother app that support 3D models…

Thanks for the attention

Please try loading your model in an existing viewer first, like gltf-viewer.donmccurdy.com/ or sandbox.babylonjs.com/. If it looks correct there, your application probably needs better lighting, like an environment map. If it doesn’t work there, you may need to review the documentation of the Blender glTF exporter to make sure your materials are set up correctly in Blender.

Sorry for the delay, your tips worked, but then I found another way to compress my 3D model, using DRACO compression. Anyway, thanks for your attention and help.