WebGPU example not working in Ubuntu 20.04

I tried to run the WebGPU example in Ubuntu 20.04 and failed. I use Google Chrome Dev (version 105) which i run from command line like this: google-chrome-unstable --enable-unsafe-webgpu --enable-features=Vulkan.

After running the example I get a warning in the DevTools Console - GPU connection lost, and white screen:

If someone faced a similar problem, tell me, please, how can I solve it? Thanks and sorry for my english.

Does it work if you upgrade Ubuntu to the latest release?

I assume this is some sort of GPU driver/OS issue that can’t be solved at browser/app level.

Ubuntu and video card drivers updated to the latest versions. Could this issue be due to poor Vulkan API compatibility with my integrated graphics card - Intel(R) HD Graphics 520 (SKL GT2)?

If open chrome://gpu/, you can see that Vulkan and WebGPU support is enabled:

I have the same problems on Manjaro Linux and a Nvidia GTX 1060.
https://webgpureport.org/ shows the same results as on Windows where WebGPU works.

Does anyone managed to run WebGPU under Linux?

If I run the examples from under Windows, they also work correctly.

After testing some examples, I found that the DevTools console throws different errors:




You might want to ask the WebGPU devs for advice. Use the following Chat channel: https://matrix.to/#/#WebGPU:matrix.org

1 Like

Thanks for the link. I’m forwarding this question to the WebGPU developers.