Unwanted lensflare reflection in ocean shader

I have a setup here with the water.js and lensflare.js.

My close hexagon flares are making an unwanted reflection in the water shader.

How can I get them to not reflect? (They’re only artifacts for the virtual camera to see not objects in the environment.)

Settings in their texture possibly?

Example: link


I’m finding the shader’s reflections are from a second flipped camera.

Is there any way to cancel visibility of the specific hexagon lensflare.elements or its texture just for the flipped camera?