Trying to disable recieving shadows and casting shadows to one object

So i have been trying to disable shadows entierly to a object in three js the only thing is that the shadows still render darkness on sides.

Could you share a screenshot / code? Kinda hard to help with the amount of given information :smiling_face_with_tear:

I was in a hurry writing this, but for more context; I was trying to make an object not receive shadows but it stills renders it even though i put the code

OBJECT.receiveShadows = false

But what im trying to accomplish is to make a skybox and skyboxes do not have darkness in different sides, or shadows in different sides.

i could send you a screenshot if you dont understand

ah I’ll give you a screenshot to explain

this is inside a cube ( its the skybox ) it still has shadows and i just want the shadows to be disabled and just be all white like the color i gave it but ill add textures after its fixed.

Instead of plural:

OBJECT.receiveShadows = false

try singlular:

OBJECT.receiveShadow = false

Reference: Object3D.receiveShadow

However, receiveShadow is false by default, so you need to disable it only if you have already enabled it. If it does not work, then the dark area is not a shadow, but something else, like wrong normals or lack of light from required direction.

i just want … be all white like the color i gave it but ill add textures after its fixed

Have you tried MeshBasicMaterial?


oh i just typed receive shadows without copying and pasting it which i wasnt sure about but that isn’t the problem, and also MeshBasicMaterial worked thanks!

1 Like