Transparency with MeshStandardMaterial

how can i do to make the model render right?

new GLTFLoader().load(model.tree,(gltf)=>{
        tree = gltf.scene;
        tree.children[0].children[1].transparent = true;

the model i expect:

the model now i get

I know little about rendering and alpha.Hope someone can help me,Thanks!

the model which i make by SpeedTree APP export with blender using alpha blend(blend Mode)

How does it look like if you remove this line and just use the material configuration from GLTFLoader?

Still as it is after remove this。 :shushing_face:

Notice that the mentioned line of code had no effect since children[1].transparent does not exists. You have to access transparent over the material property.

Can you please share the glTF asset in this thread?

It’s my mistake.And I found that the default transparent value is true.
The single gltf file is too big, I split them.

tree.bin (468.1 KB) tree.gltf (12.4 KB)

I’m unable to load your asset although I have downloaded all files from your post. Consider to share a single glb file via Google Drive or a similar service.

link: secret: 4eo5
Is this ok? :grin:

Asides of the seemingly inverted alpha mask, you won’t get a right result with transparency as faces of a single geometry or close/intersecting meshes aren’t sorted and will start overwriting each other, instead use alphaTest. You can also enable alpha to coverage if MSAA is used for smoother edges.

You find topics around the (general) transparency problem in this forum too with various approaches, but the most common used and good-enough looking option is alphaTest.

It seems I’m not able to download the asset without having an account.