Threejs Editor GLTF export fails


When exporting a Blender scene to GLTF 2.0 for subsequent adjustments in the Three.js Editor, I often encounter export errors, particularly when incorporating models from the BlenderKit collection. Deleting specific models allows the export process to resume successfully. Additionally, I attempted to isolate the problematic model by selectively importing individual models into the Three.js Editor in it’s own scene. Surprisingly, the export to GLTF succeeded when only that specific model was present in the scene. I feel like i’m doing something seriously wrong, as it seems counter intuitive that selecting a model I like requires a subsequent check for successful export from the Three.js Editor. Any idea what’s going on here?

It looks like you have augmented the objects with some additional data or there is an animation playing on the object when you’re trying to export it?
Can you try exporting it without animations?

if you’re trying to create your own animations in code… check that they are well structured and have proper .name s on the channels etc.

I have checked if the object had any animation and it didn’t, in fact there are no animations in my scene whatsoever. I’ve also tried different options when exporting the GLTF from Blender, but nothing seems to work. I’ve tried to see if I can disable animation in the Three.js Editor, but can’t seem to find a disable function for that either. Not sure if there are any other options that should be adjusted. I also wondered if the object/model had material not supported by Three.js, but in other cases where I created my custom objects with unsupported material, it ignored material but could still export.

I wonder if some animation parsing might be getting confused about which model it targets, the error at least seems to be coming from an animation-related path.

Do you get the same error if you test from an “incognito” window in Chrome or another browser?

In any case this seems like a bug, it should not crash like that, if you can share steps to reproduce the issue (including models required) then I think someone can debug and fix it.

I’ve mostly used Vivaldi for this, but I tried it in incognito mode as well as in Edge. But after dealing with this for two days and after reading your suggestion to try a different browser, I downloaded Firefox and it worked! Does this have anything to do with caching? On top of that, model feels a lot smoother and “glowing” effects look much better, even though its not really glowing yet but i’m hoping to fix that in code later.


I recommend using chrome for development unless you enjoy debugging mysterious browser quirks/bugs. :smiley: Or at least make it your first stop when hitting mysterious behavior.