Some GLTF textures are black

Blender (these are baked textures, no lights):


The sandbox:

And the blend file: untitled.blend (678.5 KB)

Anyone knows what the cause could be?

I’m having trouble with the .blend, it doesn’t show textures for me even in Blender (with the Blender render mode enabled etc.)… do you get the same result exporting this file without Draco?

oh, i just googled it. i should have saved the textures first, otherwise they won’t be put in the blend file. still a complete beginner :-S but they should be included in the gltf at least. i will try removing the compression.