[Solved] Darker Textures when exporting with GLTFExporter (GLB)

My texture gets darker when I export my scene and then import it back. I tried following the suggestions on this post, but none of them worked for me. I know that the exporter removes ambient lights from the scene so I added mine in and the texture is still dark and unaffected by the light.

Setting these two, did make the imported scene lighter but it also made the original scene more lighter
renderer.gammaOutput = true;
renderer.gammaFactor = 2.2;

made the scene darker

The last suggestion had no effect on the scene. I am using MeshStandardMaterial for the mesh that is applying the texture with metalness 0 and roughness 1. I would appreciate any help, thanks.

I also tried to reproduce this on the threejs editor but I couldn’t get it to happen. I looked at where they’re creating the renderer but the only extra thing they had was gammaoutput = true which made both my scenes lighter (one more than the other). I looked at the loader and couldn’t find anything that stood out there either.

This post fixed my issue., answer by @Mugen87, setting gammaOutput = true and texture.encoding = THREE.sRGBEncoding;