Object .glb texture does not respect shadow

Hi everyone, I have an object in .glb format like this (usign windows visualizer 3D):

But when I try to import in threeJS appears like so:
Even when I try to put some light like direction, area, ambient the result does not change.
What I have to do?
This is my code that I use to import glb file and set to scene:

const loader = new GLTFLoader();
      (gltf) => {
          (child) => {
            if ((child as THREE.Mesh).isMesh) {
              const m = child as THREE.Mesh;
              m.receiveShadow = true;
              m.castShadow = true;
              (m.material as MeshStandardMaterial).flatShading = false;
            if ((child as THREE.Light).isLight) {
              const l = child as THREE.Light;
              l.castShadow = true;
              l.shadow.bias = -0.003;
              l.shadow.mapSize.width = 2048;
              l.shadow.mapSize.height = 2048;
        const model = gltf.scene.children[0];
        model.position.set(0, 0, 0);


        gltf.scene.scale.set(3, 3, 3);
        const box = new Box3().setFromObject(gltf.scene);
        const c = box.getCenter(new Vector3());
        gltf.scene.position.set(-c.x, -c.y, c.z); // center the scene

Thanks for replay.

It may be your materials metalness channel, try setting material metalness to 0.5 and see if that makes a difference

1 Like

Yes, setting: (m.material as MeshStandardMaterial).metalness = 0.5; works.

1 Like

Sorry again,
I have another object, but even I try to setting metalness to lower value it does not change.
On windows visualizer 3d:

In threejs appear like so:
The lights does not affect the brightness of object.
Is there another property to set?
Thanks again

hi it’s difficult to say what the problem is from the small image provided, can you either share the asset in this thread or provide a live example of your environment to assess?