Newbie - I click on my model and it moves, I'd like to stop that

Newbie question

I imported a GLB into:

Here is my project:

My problem is when I click on any area of my model, the model shifts position in the oposite direction. For example, If I click on the top left part of the model, it shifts (moves) down to the lower right. Then if I click “off” of the model it returns to it’s original position. I would like to stop the model from shifting around like that. Is that possible? I’d like the user to be able to rotate the model, it’s those unwanted shifts in position I’d like to stop.

If someone is kind enough to advise me on what to do to stop that movement could you please also let me know which file to put the suggested code into? I know html and css but I know very little javascript. Any information would be greatly appreciated.


1 Like

Does adding the disable-tap attribute to your model-viewer tag solve the issue?