How to improve the quality of textures when close to it

I have scene where camera zoom in to monitor, but the problem is when it close, texture looks bad.
Scene and textures are from blender(.gltf). I baked texture for the scene in 4k(because phones support only up to 4k).
I tried bake in 10000 samples, denoise, or bake 1 wall at a time but no help. How to make it looks good at least walls.

1 Like

check if its the same in blender, it could also be compression artefacts. if you use tools like gltf-transform or gltfjsx they can use webp compression because textures cause most of the weight. gltfjsx for instance goes to 1k webp by default unless you choose a higher res.
another fix would be to use more textures. if the whole scene is using one texture atlas then 4k might not be enough because the walls will take up a tiny fraction of the space available, so just use more atlases.

1 Like

Yes, its looks the same in blender, but it isn’t so visible in blender, and compression artifacts as well because I save bake in jpeg. I still don’t understand why it’s so bad quality. I used 2 texture for room and desk, but right now I use one texture for walls only. Here is my blender bake settings:

Thanks for help.

Is there a reason you’re not using the denoiser?

well i tried, but it doesnt make difference. It makes waving

Hmm but looks like it IS smoothing some of the noise… maybe just have to tweak it?

you mean denoise parameters?

ya or maybe the noise threshold or like… less samples more denoise, or more samples less denoise. I’m not an artist, just a programmer. :smiley:

1 Like

same. I tried to change denoise options and it doesn’t make changes. I google it and people denoise from Compositing Workspace and they denoise from render layers, but denoise from texture file. and i have only two options, fast or accurate. Neither of them work.

Try baking into 2048x2048 - linear interpolation will kick in for the textures and blend the artefacts.

But if you’re baking detailed color textures, not only indirect lighting, for more complex scenes you’ll need to bake texture per-model. Otherwise you’re running out of real estate on the texture and decrease quality quickly.

I found the solution to this problem after a ton of testing. So, the problem was in color space of bake image. I was baking in linear, but it makes artifacts more visible, picture more bright, and if I use denoise make wavy. I tried all of them and the best for is sRGB. It makes render same as blender.
Also, some of you said file format make different too, but I didn’t check how bad it is. For now I use png, no compression.


Oh nice glad you figured it out. Appreciate you posting your findings! :slight_smile: I’m sure this will help someone (me) at some point. :smiley: