Seams on texture

I made a model in a Blender and decided to bake texture because I need a special effect of the lights. After baking and exporting, my model has lines of its own. I try to fix lines with minFilter but no luck.

gltf.scene.traverse(n => {
        if (n.isMesh) {
            n.castShadow = true;
            n.receiveShadow = true;
            if ( {
                n.material.vertexColors = false;
       = 16;
       = THREE.LinearFilter;
       = THREE.LinearFilter;
       = THREE.sRGBEncoding;
       = uniforms.texture.value.wrapT = THREE.RepeatWrapping;


First solution - increase texture size.
Second solution - increase UV percision to 6 digits like 0.006857
Third solution add texture padding in blender.
Fourth solution use phoshop texture filling by content.

Fifth solution: your uv splited by triangles. Need merge triangles .Then you can use small texture


this is my texture

all your triangles are touching each other - give them some personal space

I will try with this UV

I use 3ds max and flatten mappin or box unwrapping

Into 3ds max texture baking - padding

I do not know how to use 3ds max, I added space in blender but I still have seams. :pensive:
and I am not good at uv mapping so i use “smart uv project”. Do you know some trick to fix this in three.js?

Somedoby help you. I have blender, but dont know how to use him

i use UVPackmaster 3 - Blender Market and it’s a thousand times better than smart unwrap. it also warns you if it detects overlap and otherwise fixes it by packing texture islands.

1 Like

Thanks a lot I will try and let you know

Is there a free version?

Where I can do this “increase UV percision”? I have tried all the other solutions and they are not good

Best solution - good UV unwrap.

I try blender. Into up of menu select “UV Editing”. Select vertices of your object.

Into menu select “UV” and “Smart UV Project”

Change setting there
I got good uv unwrap