Have problem with particles on iPhone 14 or ios 17

I’m using the example from this site particle │ sketch of three.js, it works perfect, but in iPhone 14 or iOS 17 it shows black screen

there is also a codepen example https://codepen.io/ykob/pen/WpNxaR that doesn’t work too on some devices

console not throwing any errors or warnings

any idea what problem is ? and how to fix it

1 Like

Might be that its using floating point rendertargets and/or RGB format instead of RGBA format… idk

Yes it is, in codepen example author uses RGBFormat

I tried to use RGBAFormat, but the attempt was unsuccessful

For that format, you have to have 4 components per pixel in your texture, whereas there are just 3 components in the example (because of RGBFormat, obviosly) :thinking:

1 Like

Yup. And in the codepen provided, I adjusted the datatexture construction to accomodate the .a channel and it didn’t break, but I don’t have an ios device to test whether it made a difference.

Heres my updated codepen:

@s2567k Can you try running this one on you iOS device?

nope, still doesn’t work

1 Like

any idea how to fix it ?

Does this particle demo run: FBO

1 Like

yes, this particles working correct

Hmm ok… I wrote it a loong time ago but it’s also using float rgba rendertargets for the particle system.
So… I’m not sure why that other one isn’t working…

The code is unobfuscated if you want to take a look, maybe you can spot something.