glTF model loaded , but without texture

Hello , I have a .glb model that is rendered but without texture , what should I do?
I’m loading a .glb file using this code :

            var world = new THREE.Group();
            var mesh = new THREE.AxisHelper();
            let loader = new THREE.GLTFLoader();
            loader.load('assets/models/FBX/model.glb', function ( gltf ) {

                    gltf.scene.traverse( function( node ) {
                       if ( node instanceof THREE.Mesh ) { 
                           node.castShadow = true; 
                           node.receiveShadow = true; }
                    } );

                    world.add( gltf.scene );
            }, undefined, function ( error ) { console.error( error );} );

The code above is working with any other .gltf models , but with this one it doesn’t load the textures / materials.
The thing is , I’ve already followed some steps seen on this website like : testing the model on a online viewer tool or using the callback function to log the errors for example.
When I render this object , I don’t get any errors / warnings.
Even more : on the online gltf viewer tools the model seems to look the same ( it renders without any textures / materials ).What should I do?
I mean , ok , I understand there’s a high chance to have a bugged / non-functional model (if the online viewer tools are displaying the same results), but what should I do?

Thank you for help!

P.S : Yes , even if it’s ‘…/FBX/…’ path , I’ve used a fbx to gltf2 online converter and got a .glb file

You can try to upload your model to Sketchfab and then export to glTF. This approach could be useful to verify if FBX2glTF has maybe problems with your file.

1 Like

Hi @Mugen87 and thank you for help , I’ve tried your idea , I went to sketchfab and uploaded the model.
The thing is I couldn’t upload the entire model cause of the upload limit size.So I’ve included only the .fbx and the animations(all of them).The result was : the 3D model had no texture(which it’s normal because no texture files included) but it didn’t had all animations either , there was over 20 animations and only one was included … I think it’s the first one.
Got the same result when I uploaded the same documents but instead of the .fbx original file it was the .glb converted file.
What do you think?

The model is actually bought from sketchfab , shouldn’t it work 100% ?