Geometry looks bad after using Draco compression

I export a glb file from 3DS Max with BabylonJS tool, the geometry is a bit out of shape after using Draco compression.The shape is totally fine without Draco, but the file size is too big,almost 7 times bigger.
Any idea to solve this?
My BabylonJS settings below, it does not matter if I check the ‘Try to optimize vertices’ option, the result does not change at all.

Can you share the file? Is the result different if you export it without compression, and then add Draco compression using instead?

1.Sorry, the file can’t be shared.
2.Yes, the result is different without Draco compression
3.I’ll try this, but I don’t know how this work with 3ds max?

I solved this with the gltf-pipeline.
The major problem here is the default property draco.quantizePositionBits in BabylonJS plugin, and there isn’t an option to change this. I change this to 20, then everything is fine.
THX for your help, man, really appreciate it

Nice! It may be worth filing a bug on the BabylonJS plugin in that case, too.