Disable skinning temporarily, Possible?

I want to move a selected mesh temporarily to world origin for inspecting it’s materials/textures,
this works well for all the normal meshes , but in case of skinned mesh it stays stuck to the bone and does not move as intended

is there any way to temporarily disable the skinning effect on the mesh ?
Removing/changing the parent mesh does not work

maybe someway to disable the skinWeight and skinIndex in the mesh’s geometry attributes ?

The engine detects skinned meshes by the isSkinnedMesh property of the SkinnedMesh class. It’s a hack but maybe it works if you just assign false to it.


OMG! that works ! i though it was a read only property