Ar/Hit test Example not working

This demo is not working!

What version of Chrome are you using? Are you also using an Android device?

One tip: It is in general not professional to report issues by just saying “something is not working”. There is also no need for the exclamation mark.

You have to provide more details so a meaningful analyzes becomes possible. For example, do you see any error messages or warnings? If so, please share them.

I using Google Chrome : 80.0.3987.149 in ArCore supported android device.Other all examples are working fine beside this one.
No Error is coming. “Start AR” comes at the bottom of the screen but on pressing the button nothing happens.
I am attatching the screenshot of my android device.

The example says at the top you need Chrome 81+ (and also enable specific flags).

I tried with Google Chrome : 81.0.4044.71. Enabled all the flags .Now no example is working and “Start AR” button is also not coming.

I also tried with Chrome Canary : 83.0.4095.0. But in this #webxr-ar-module and #webxr-hit-test flags are not present rather only one webxr flag ie WebXR Incubations is present. Due to this no example is working and “Start AR” button is also not coming.

Please help with the solution

I’ve tested both AR examples with Chrome Beta (81.0.4044.71), enabled both flags and the result is as expected. I’ve used a Pixel 1.

Just to be clear: The screen is also black but as soon as I click on the START AR button, the device is asking for permissions to start an AR session. After submitting this dialog, the camera becomes active and the demos are ready to go.


I am also testing with Chrome Beta (81.0.4044.71) . I tried on Oneplus 7t as well as Xiaomi Pocophone F1 .Both support Arcore but I am facing the same issue ie no example is working and “Start AR” button is also not coming.

Do you see any errors in the browser console? To check this, you have to connect your smartphone with your computer, enable USB debugging and use the inspection tools of the (desktop) Chrome (chrome://inspect/#devices).

I have checked in the console there is no error

Sorry, I’m out of ideas…