Animations stop working after upgrading from 120 to 124

Another issue going from 120 to 124
Not only do the shadows not work, but my animations stopped working on any that have more than 1 animation.
Some dont work at all and others give this error.
TypeError: Cannot read properties of undefined (reading ‘uuid’)
at AnimationMixer.clipAction

All worked fine in 116

ideas? :slight_smile:

I also just tried my glb file in your viewer and does not play there either.

Attached is that file if you can take a look
Here is the GLB file

It does not work with BabylonJS, too:

I guess there is something wrong with your asset.

Well Im just curious why it worked fine before. I guess I can just use a older loader, but hate mixing. Plus the other ones error on animation too, mine did not error just would not play.

The other problem I had with 116 was the reflector, so I just went back to 116 and changed the Reflector.js to 118 and that seems to fix it so I guess it was an error in the 116 Reflector script

I also read there was some type of change to LIght Shadow in 120, so maybe thats why might shadow-true is not showing shadow and shows so many shader errors. Like I said before I know it works in 124 from samples on my site, but it would be hard to track down in my code as it could be soooooo many things.

So right now I am stuck on 116 unless I can figure shadow issue and anim issue