My glb animations works in everything BUT three server, it loads in and they even move around but wont do armature actions from bones

I tried to look at many discussions to solve this but none had the full fix.
So pretty much my glbs animation works in another three project when I run npm run dev, it also works when i upload to babylon and also but when i tried to open in another project that is “self contained” objects move around but my characters dont perform their animations and stay in t pose… I made the glb in blender btw here’s my three code
GitHub - BLE77/gogoTHREE

also again im sorry for bugging you all i def tried to find the answer before asking
and this a screen shot of what is potentially the problem but i can find how to fix

I’ve updated your scripts.js file to use the latest files of the engine. Imports look like so now:

import {
} from '';

import { GLTFLoader } from '';
import { DRACOLoader } from '';
import { OrbitControls } from '';

The examples works as expected then. So it seems you are using outdated library files.

BTW: The colors of your scene are wrong. You have to add this line to your renderer:

renderer.outputEncoding = sRGBEncoding;

This work also if anyone is wondering since this is a “self contained” and i cant use external resources in the project itself, i just downloaded the master again from the three website and took the loaders from there.