Adjust "emissiveIntensity" of LineBasicMaterial while using UnrealBloomPass?

Hello every! we’re facing a problem while combining line materials and bloom pass together:

The LineBasicMaterial do not have a emissive emissiveIntensity and emissive props, but it indeed renders a bloom effect while using UnrealBloomPass as the following example:


How can I control such an effect (reduce bloom effect) properly?

Code example:

PS: I can’t adjust the parameter of UnrealBloomPass directly, since it there’re other objects share same bloom pass with these lines, and I have to make sure all the objects renders properly…

You can try the approach with selective bloom:

1 Like

@prisoner849 Thank you for the solution! it’s a little bit difficult for me to understand everything the code is doing, but I’ll continue trying

Some explanation: Selective UnrealBloomPass issues
and examples:

@prisoner849 I made it successfully (but have no idea why :joy:)