Zooming in camera make some meshes not visible

Im using OrbitControls and when i zoom in or move camera on some angles some of the meshes disappear. This is my camera configuration right now :

camera = new THREE.PerspectiveCamera( 60, window.innerWidth / window.innerHeight,0.1, 3000 );

I tried to decrease the near plane but it doesnt work, i also add to the meshes materials that are disappearing THREE.DoubleSide and nothing seems to work. They are also animated via new way to animate fbx.

object.mixer = new THREE.AnimationMixer( object );

mixers.push( object.mixer );

var action = object.mixer.clipAction( object.animations[ 0 ] );
action.play();

Don’t know if that has anything relationship with the issue.

This a project test to check what i’m saying:

test.zip (800.7 KB)

Thanks!

You might want to set object.frustumCulled to false in order to prevent view frustum culling.

2 Likes

I put that but i doesnt seems to work.

Are the meshes disappearing only when they are animated?

Probably i only check them animated…could be a problem because of that ?

Arrows.zip (196.8 KB)

Here’s actual model @turkoz14 is having problems with, from the GH issue.

I edit this because i realize what you are saying.

I have checked your code. You have to disable view frustum culling for all objects, not only for the top most:

flechasObject.traverse( function( object ) {

    object.frustumCulled = false;

} );

After applying this code in your onLoad() callback, everything works fine.

Yes. Bounding volumes like bounding spheres do not respect the vertex transformation performed on the GPU by vertex morphing or blending. Since your FBX asset contains skinned meshes, it’s best to disable view frustum culling in order to avoid your reported problem.

2 Likes

Thanks, now its working great!

Yes! That does the trick for me. Thanks, jb