Why AdditiveBlending only works on backface on plane geometry?

I am trying to understand how blending works. When I use plane geometry, then meshes only blend from behind, I can’t find any info on this behavior.


You can easily fix this by making both objects transparent: Edit fiddle - JSFiddle - Code Playground

Why do you use opaque objects?

Thanks for responding.

Actually issue I am facing is with instanced mesh, where I was using transparent objects. I just thought I would post simpler code as it was happening with simple plane geometry as well.


Um, how about setting depthWrite to false? Edit fiddle - JSFiddle - Code Playground

1 Like