Unable to see shadows on ground plane

I am unable to get any shadows in the scene…
As far as I can tel I have gone through all the required steps:

  • Renderer - shadowMap is enabled
  • All objects in the scene can cast shadows if the are DynamicMesh
  • The ground plane receives shadows
  • I visualized the shadow camera to make sure the frustrum was OK

Do you have a shadow-casting light?

I do

What type of texture are you using for the ground?
MeshBasicMaterial does not accept shadows.

I am using MeshPhysicalMaterial

Maybe model without option castShadow. You can try create simple box to test shadow.

I see that the light position is only 1 unit away and that camera near is also 1.
Could that be the problem?

If not, is there an ambient light that is overwhelming the shadows?

1 Like

There was an ambient light that was quite bright…
Turning that one down, and removing physically correct lighting made it look a lot better

I’m glad that helped. Since using shadows, I have been turning down my ambient light significantly, generally to around less than 0.1.