THREE.POINTS not appearing in transparent material refractions

here, a box with default r3f material, some three points and a black refractive plane in front
the box appears as intended, but the plane for some reason refuses to let the three points thru, any idea why & how to fix this?

I’m guessing your PointsMaterial is transparent. Not sure what you’re using for refractive material, but if it’s based on MeshPhysicalMaterial then it transparent materials won’t appear in the refractions as the WebGLRenderer only renders opaque objects in the transmission pass ( a render pass used to create the transmission map for the material ).

Solution would be to either modify the WebGL renderer so it renders transparent objects in the transmission pass, or switch to a non transparent material for your points.

thanks for ur reply appreciate it

i can’t find any settings regarding rendering transparent objects in transparent pass tho, i only found settransparentsort but i don’t think that’s what needed here?

also i’m using r3f shadermaterial for points if that’s relevant, but yes they’re transparent

It’s the transmission pass that needs to be modified to render transparent objects, the transparent pass doesn’t need to be modified.