Sky example colors after r118

after r118 upgrade the Sky example had changed its tonemapping function from hardcoded (uncharted) to the tonemapping function configured in the renderer. The problem is that I can’t find a configuration of parameters (even playing in the examples page) to have a blue sky like it was before.

Any suggestions?

You can restore the old tone mapping function by defining a custom tone mapping like in the following example:

I am facing the same issue as the OP while updating my dependencies.

I don’t fully understand your answer. From my understanding, you suggest to change the tone mapping function of the whole scene by a custom one. But I don’t really see how it would solve our issue. Currently, I use linear tone mapping for my scene (with renderer.toneMappingExposure = 0.0001) and I was able to adjust the brightness of the sky shader with a setting exposed by the shader. But now this setting is not exposed anymore. My issue is not the tone mapping function in itself, it is the brightness of the sky (which currently is full black) in comparison with my scene.

From my understanding of your solution, I can either have an overexposed scene with a “normal” sky or a black sky with a “normal” scene. Or something is wrong with my scene and I should not have such a low toneMappingExposure value ?

Thank you for your reply

The hardcoded tone mapping function was removed since it is much cleaner to embed the tone mapping shader chunk from the core which is used by all built-in materials.

However, Uncharted2ToneMapping has been removed with r118. Hence I suggested to restore it if necessary by defining a custom tone mapping function like demonstrated in the example. Of course that means you have a single tone mapping for the entire scene. But this is actually the way to go. Using different tone mappings for objects is actually not good.

I understand that means that you can’t achieve the exact visual appearance like before. In this case, it’s probably best to create a custom version of the sky shader and use the code from r117.

You are right, thank you for your input. Actually, I noticed that I am currently using tone mapping mainly for the exposure functionality it provides, as my scene was completely burned (white) without it. But I now understand why: I thought physicallyCorrectLights = true would allow me to set 32000 lux of intensity to a DirectionalLight, but I just learned DirectionalLight disregards physicallyCorrectLights = true. This resulted to an intensity of 32000, which obviously was burning my scene.

So I guess I have to abandon the idea of setting physically correct lux intensity to my sun…