Postprocessing Transparency Issue

I’ve been following this example to create a glow effect around the sun.

I modified it slightly so the objects I want the bloom effect applied to are in their own scene instead of traversing scene objects and modifying their materials; this seemed to achieve the desired effect.

See this codepen.

However, I noticed that it makes the sun translucent and I can see other scene objects through it. Is there any way around this? I’m using the same shader code as the example, perhaps there’s an issue there?

Also, I found this reply stating that setting a scene background somehow disables the bloom effect. Since I had two different scenes, I thought I could set a background texture in the non-bloom scene but this doesn’t work. Is there any way to set a background image and still preserve the bloom?