OBJ+MTL Texure loads but only on some devices

Hello to all.
I’ve manged succesfully load obj+mtl files onto html -> Showcase but hit an unusuall issue.
Textures renders OK on iOS device (Macbook) on any browser (Chrome, Firefox, Safari), but the object stays black on Ubuntu 20.04, Ubuntu 18.04, Windows 10, Windows 7 on any available browser.
It renders OK on Huawei P30 Pro as well as on Huawei P9 Lite and Samsung Galaxy S10+ but it won’t render on Xiaomi Redmi 7 and any iPhone (5, 7 and X)

No Errors or Warning in DevConsole.
Have no idea what could be the case. Any thoughts ?

No, not really. Do you see the same issue with the official OBJ/MTL example?


BTW: Consider to convert the OBJ/MTL file to glTF. This should noticeably decrease the file size of your asset.

Have no issue with official OBJ/MTL example on any PC (Ubuntu or Windows) but it stays black on Huawei P30 Pro (this one I have on me - I will test others later) - which works well with my showcase.
As for the gLTF I’ve tried and the files was much larger than obj+mtl
Even tried with https://blackthread.io/gltf-converter/ and its also bigger.

I’ve imported the OBJ/MTL asset into Blender and exported a DRACO compressed glb file with 9 MB file size (with texture!). Sorry, I can’t upload it to the forum.

OK - fair point. But it is not my choice - client has 3d models in obj/mtl files and issue is with them.
I haven’t found the key why some devices refuse to render textures.
Is my showcase working for you?

Yes, I have tested it on an iMac (with Chrome, Firefox and Safari). The showcase works fine.

BTW: You can remove the usage of DDSLoader from your showcase since your asset does not use S3TC textures.