Mesh Vertex color darker than original


I’m trying to use Vertex color from an FBX file that came from RealityCapture made with photogrammetry, the color of the mesh in three is darker

As seen, the mesh in reality capture and in blender is bright, but in the browser it’s darker.
I’ve seen similar issue posted here but I can’t get the same result, the answer says to make the color white (0xFFFFFF) but no difference was made when made white (though if changed to 0x000000 it will turn black).

there is no light in the scene, I just made the background white. Is there an option or setting I need to change?

Note I used emission shader in Blender and I assume Reality capture use the same, but I used MeshBasicMaterial so shouldn’t it has the same brightness?


Does anyone has a solution or suggestion?


glb.scene.traverse(e=>e.material && ( = THREE.LinearSRGBColorSpace))


glb.scene.traverse(e=>e.material && ( = THREE.SRGBColorSpace))
1 Like

I’ve tried switching the RGB color space but the brightness remained the same.

So I’ve tried to vertex paint a model and load it in threejs and the brightness and colors are correct! so it seems the vertex “type” or some other thing is affecting the model. :melting_face: